ヘッダーイメージ 本文へジャンプ
日記

2012年02月28日 13時59分
RAID のできるSATAカード
現状 Windows7 のマシンをサーバーにして、ファイル共有とVMServerを動かしているので、チップセットの機能でRAID1を組んだところを、ファイル共有したりVMのイメージを置いたりしているのですが、VMserver のバージョンも進まなくなってきたので ESXi5 に移行しようかと思って調べていると

ESXi5 はチップセットの RAID には対応していないようなので、いろいろ探してみました

結果としては私が思っていた価格帯では買えずお手頃価格の
を買ってみました

気を付けるところとしては、(マザーボードによるかも知れませんが)SATAディスクを付けない状態でカードを付けるとブートできなくなるようです
単にタイムアウトが遅いだけかもしれませんが、BIOSの設定画面にも入れませんでした

で、いろいろ試しましたが、ESXi5 では RAID1 を組んでいても SATA 2台で認識します
やっぱりソフトRAIDなんで対応してなければこんな感じでしょうか認識しませんでした
(2012/3/30 もう一度試したら認識しませんでした・・・)
でも、PCIカードをゲストOSにパススルーできるので、Windows7のゲストにマウントすると RAID OKでした
(軽く試してスピードを確認しただけです。因果関係はわかりませんが一度ゲストOSがフリーズしました・・・)

が、スピード的に4.5Gぐらいのファイルを転送したところ30Mぐらいの速度でした
ATOMにカードを付けてWindows7を入れた物理PCで試すと50Mぐらいは出るのでオーバヘッドが結構あるようです
ちなみに、現状の Core i7 で Intel の ICH10R のチップセットで RAID1 だと 100Mぐらい出るんですよね・・・
ネットワーク挟んで(もちろん1000Mですが)です「.ほんまかいな!」って数字ですが、ストップウォッチで計って容量/秒数で計算しても確かに100MB(バイト)/S以上出てるんですよ!

それみちゃうと、VM はちょっと・・・

という事で、ファイル共有の方は消費電力は増えますが ATOM なマシンにPCIカード指して RAID1 で使う事にしました
ESXi5 の方は、1TのHDを2台入れて、日々自動バックアップするような設定でもしてみます

今回使いませんでしたが、このカードマザーボードを選ぶのかもしれませんがBOOTできました
BIOS の BOOT シーケンスを設定するところに、HDの名前が並びました(RAID 組んだら V-RAID って名前が出たと思います)
残念ながら、IDE 接続で DVDドライブをつないだんですが、こちらはBOOTできませんでした

また、1TのHDを2台つなげたんですが、VISTA 64ビットだとフォーマットできませんでした
RAID1でも NON-RAIDでも、95%ぐらいまではカウントを見たんですが、最終的に失敗してしまいます
(5・6時間かけてです、もしかしたらドライバーを入れ忘れていただけかもしれませんが)
Windows7 だと、何もインストールしなくても、ちゃんとフォーマットできました

そうそう、CDからユーティリティソフトとして、RAID を組んだり、たぶんリビルドとかするソフトをインストールするんですが、インストーラーで「ログオン時に自動実行するか?」と言うようなことを英語で聞かれ、これに「はい」を答えると確かに立ち上げてくれるんですが、Windowsの UAC に引っかかって毎回立ち上げても良いか聞かれます

私はインストーラーでは「いいえ」をこたえ、ログオンのタイミングで実行するタスクを作成し、そのタスクの「最上位の特権で実行する」のチェックボックスにチェックを入れ、起動するようにしました
こうすると、UACに引っかからずに実行されます

ただ、ATOM だからかもしれませんが、タイミングの詳細設定で遅延時間を5秒ほどに設定しないとうまく実行されなかったです(プロセスとしては動いていたので、Windowsのシェル(?)が起動する前に動いてしまっているのかもしれません)






こんな感じです

まぁ値段を考えると、良い拡張カードじゃないでしょうか?

それにしても ATOM 結構いい仕事するなぁ!



カテゴリー:日記
目次へ戻る


フッターイメージ